[главная] | [каталоги]

создан: 2019-08-28 09:32:35
пользователь: cloud раздел: техника
[просмотров|53]
Mikrotik hAP (RB951Ui-2nD), USB modem e1550 huawei, yota

Mikrotik, usb modem, yota, e1550. Настройка usb модема на основании роутера mikrotik, переподключение, usb power-reset, планировщик скриптов mikrotik

1. Interfaces

ppp-out1



2. System - Scripts
Add new -> name: ping


:local PINGCOUNT 3;
:local PINGIP "8.8.8.8";
:local PINGRESULT [/ping $PINGIP count=$PINGCOUNT];
:if ($PINGRESULT > 0) do={
} else={
/system routerboard usb power-reset duration=15s;
}

3. System - Scheduler



On Event: /system script run ping

4. при необходимости:
изменить AT команды модема
Terminal:
system serial-terminal port=usb1 channel=2 (перебирайте channel, в моём случае я подключался к модему через 2)

в появившемся окне наберите:
AT
если канал правильный, то появится ответ:
OK

для сброса на заводские настройки, команда:
AT&F

AT^CURC=0 (для того чтобы модем не сыпал в порт RSSI (Received Signal Strength Indication) и прочим)

Если Ваш модем e1550, как в моём случае, то можно добавить AT-команду в "Modem Init" в interfaces - ppp-out1
AT^SYSCFG=14,2,3FFFFFFF,2,4 (режим только 3G/WCDMA) - это необходимо, чтобы модем не стал искать среди разных сетей а сразу подключался к 3G и интернету WCDMA
команды: http://garage.zabkray.net/component/content/article/9-kpingvinarium/68-m-at-commands.html
в гугле наберите AT команды для вашего модема

AT+CUSD=1,"AA180C3602",15 - команда *100#, "AA180C3602" - это и есть "*100#" - в кодировке UCS2, так как данный модем не поддерживает строки без данной кодировки
*101# = AA182C3602 - проверка остатка интернета
http://smstools3.kekekasvi.com/topic.php?id=288

расшифровать сообщения можно отсюда: https://smspdu.benjaminerhart.com/ необходимо выбрать Unicode UCS2

загрузить
ещё


зайдите на сайт

bot: [цитата] Выживают не самые сильные или самые умные, а те кто быстрее реагирует на перемены. © Чарльз Дарвин
fizord.ru © 2019
Андрей Исаков